summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-03-18 21:36:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-03-18 22:30:21 +0100
commit7897e8625ed181e6824e415be337239dbb152b0c (patch)
tree9bac640faa062508c54730ddb0637c4117fcd985 /dev-python/PyPDF2/PyPDF2-1.26.0.ebuild
parentdev-python/PyQt5: version bump (diff)
downloadgentoo-7897e8625ed181e6824e415be337239dbb152b0c.tar.gz
gentoo-7897e8625ed181e6824e415be337239dbb152b0c.tar.bz2
gentoo-7897e8625ed181e6824e415be337239dbb152b0c.zip
dev-python/PyPDF2: 1.26.0 version bump, add py3{5,6}, fix tests, EAPI 6
Gentoo-bug: 606466 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/PyPDF2/PyPDF2-1.26.0.ebuild')
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.26.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild b/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild
new file mode 100644
index 000000000000..97788638f041
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.26.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with pdf files"
+HOMEPAGE="https://pypi.python.org/pypi/${PN}/ https://github.com/mstamy2/PyPDF2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-py3-tests.patch" )
+
+python_test() {
+ "${EPYTHON}" -m unittest Tests.tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}