summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 23:00:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 23:04:23 +0100
commit08d667216a3772a88ddacc9b6f24670d5f82a5c6 (patch)
tree79168aa927b9efaf92812533266124f26805fc90 /dev-python/PyPDF2
parentdev-python/pypax: Switch to PEP 517 build (diff)
downloadgentoo-08d667216a3772a88ddacc9b6f24670d5f82a5c6.tar.gz
gentoo-08d667216a3772a88ddacc9b6f24670d5f82a5c6.tar.bz2
gentoo-08d667216a3772a88ddacc9b6f24670d5f82a5c6.zip
dev-python/PyPDF2: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/PyPDF2')
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild b/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
new file mode 100644
index 000000000000..f58c46912f0d
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="https://pypi.org/project/PyPDF2/ https://github.com/mstamy2/PyPDF2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-py3-tests.patch" )
+
+python_test() {
+ "${EPYTHON}" -m unittest Tests.tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}