summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-21 12:57:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-21 14:24:51 +0100
commitb0dfa4dfeae2f7da2db6356b582aaac8aa519c0b (patch)
tree86beaa119e9b102f7cf0bed2fded8202678536fa /dev-python/PyPDF2
parentdev-python/uvicorn: Bump to 0.20.0 (diff)
downloadgentoo-b0dfa4dfeae2f7da2db6356b582aaac8aa519c0b.tar.gz
gentoo-b0dfa4dfeae2f7da2db6356b582aaac8aa519c0b.tar.bz2
gentoo-b0dfa4dfeae2f7da2db6356b582aaac8aa519c0b.zip
dev-python/PyPDF2: Bump to 2.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/PyPDF2')
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-2.11.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 3874a43eb404..4f078f5536f7 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,2 +1,3 @@
DIST PyPDF2-2.11.1.gh.tar.gz 6460157 BLAKE2B b9b6d1801b24c2d522200636700d26f651a5c877d31d3a72a8b9a8748a8063e163644d8ce115975a122cdfa4ad9f566f932ddd5b8f2f4545c57332f6c9f34154 SHA512 d1742a96db4b1385c0d670c682dd326d2a12e4ef36bff281bdf56b5df463c1a6ae023e40a4c591afc3c7176a73ceb610f23819cdcfebd2ecca7b327c1d21cec3
+DIST PyPDF2-2.11.2.gh.tar.gz 6577234 BLAKE2B a6c7892364c54a44bf005fb105a5fd6f68beb44f54bc437d84d02978439943871ba18178ea9917c44572acc1f67b6647817fd789fcdaa8209ed6e44a0e8fcaef SHA512 4405ea7594c2d6ce691a8421f874ac551ae55f03d3bec32e7384ad0385581ecb4bdf1582f7c3f3d7da64871a80c0e5691fc5cdcafc3cb3d88e89225fd30bb788
DIST PyPDF2-sample-files-bedcbe077c4898e1b97c6c6f81d937f5048b4630.gh.tar.gz 7198720 BLAKE2B 91d177e7329fd137322972a3a38841cb0611de7f839071fe2fa5ecff0343cbffdf6976f42f4a779f520a8a2bac2d6573c5cd65bf2f1bc68395077e6e9c7322d9 SHA512 0cdaee85f1da12cf678165f06c8d351aa0808137d25f68c07f19f1bd3c929eeb52e604041dfaa0df94665379aeb7d19a43426d724a5e6602b7e4fbe7a62e753d
diff --git a/dev-python/PyPDF2/PyPDF2-2.11.2.ebuild b/dev-python/PyPDF2/PyPDF2-2.11.2.ebuild
new file mode 100644
index 000000000000..6159dc70df6d
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-2.11.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=bedcbe077c4898e1b97c6c6f81d937f5048b4630
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+RESTRICT="test"
+# 150+ tests require network, too many to deselect
+PROPERTIES="test_network"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${P}"/sample-files/ || die
+ fi
+}