summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-07 21:48:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-07 22:21:34 +0300
commitc673d0595de6baa2c8b049190c4737ecdc4f93bf (patch)
tree2c448a77252e2f68d3325fa730920d9daeeed977 /dev-python/PyPDF2
parentnet-wireless/kismet: add 2022.08.01 release (diff)
downloadgentoo-c673d0595de6baa2c8b049190c4737ecdc4f93bf.tar.gz
gentoo-c673d0595de6baa2c8b049190c4737ecdc4f93bf.tar.bz2
gentoo-c673d0595de6baa2c8b049190c4737ecdc4f93bf.zip
dev-python/PyPDF2: add 2.10.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/PyPDF2')
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-2.10.0.ebuild131
2 files changed, 132 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index a65fd600e5b4..96379f551a46 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,3 +1,4 @@
+DIST PyPDF2-2.10.0.gh.tar.gz 6355180 BLAKE2B 1070e4989609cb1361f966f06a23a972ba0f53d6d02d2f489104a7198111d4e80573e2a54d7446bd85ccc8270ad8cb592c2131f0ba1433b3c1ca246bcd39c466 SHA512 dfc543a9cbc4c4e185abc928a64a8aeb5c69d833d3af0983bc994bb6a62b65732a6ea0a7b260bca4de8854639c0a03e0cc6398a5d9ec4df9125ccf7e4b3b264d
DIST PyPDF2-2.4.1.gh.tar.gz 5121207 BLAKE2B 387085ea028d7fcbcfd5fa4e5373b655e647548093638db66fa92d44b8771bb5342f8086ebca82e205cf56f1865778bc604f49a49b39af16d8d9e3466a51653d SHA512 430e73ee6965fd6b8dac9ce8b6ee232e8ea829a7dbdfe87aafd29ae24ab182cd3e568b447030a0c199aab9049a79ce2a5518ce7fe59b1d8ce533b1313a568fc2
DIST PyPDF2-2.4.2.gh.tar.gz 5327738 BLAKE2B 5343d5b7c2efe2ed664f896b030a60ad8570ae8f481376e4ad9c865144b66d912633e4f83294d7f6399230963c02dea262cc247b10ca3c146ab24f823c0d57f3 SHA512 84a13d5b624ca8ca2dc4c474309ffa47d1770e1681ccb527f7fc1df37698037c224939dd062da004cbf7b983744afd3ab9adc9a610bea3f2f297e1ed5b708dd2
DIST PyPDF2-2.5.0.gh.tar.gz 5597332 BLAKE2B 40d4fa812f1a70c18d3b2907d83185cd79af3d722e762ec8dec9709cb5c70246c21fa124e419d8b12142b0ae22b1f13958835eaaa23e9f4cc9efbd05793db7ce SHA512 ec7560b4bb3737fe4c830f058f5303cb70c9ff660c3f40637b4b86c8c79bf11a246a3fcc425aa54b5ca160548311c7f93248a1001c75a7e1dbf3119245e3262f
diff --git a/dev-python/PyPDF2/PyPDF2-2.10.0.ebuild b/dev-python/PyPDF2/PyPDF2-2.10.0.ebuild
new file mode 100644
index 000000000000..db21f89a85ae
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-2.10.0.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=b6f4ff3de00745783d79f25cb8803901d1f20d28
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Needs network access
+ tests/test_cmap.py
+ tests/test_filters.py::test_decompress_zlib_error
+ tests/test_filters.py::test_lzw_decode_neg1
+ tests/test_filters.py::test_issue_399
+ tests/test_generic.py::test_dict_read_from_stream
+ tests/test_generic.py::test_parse_content_stream_peek_percentage
+ tests/test_generic.py::test_read_inline_image_no_has_q
+ tests/test_generic.py::test_read_inline_image_loc_neg_1
+ tests/test_generic.py::test_text_string_write_to_stream
+ tests/test_generic.py::test_name_object_read_from_stream_unicode_error
+ tests/test_generic.py::test_bool_repr
+ tests/test_generic.py::test_issue_997
+ tests/test_merger.py::test1
+ tests/test_merger.py::test_bookmark
+ tests/test_merger.py::test_iss1145
+ tests/test_merger.py::test_sweep_indirect_list_newobj_is_None
+ tests/test_merger.py::test_sweep_recursion1
+ tests/test_merger.py::test_sweep_recursion2
+ tests/test_merger.py::test_trim_outline
+ tests/test_merger.py::test_trim_outline_list
+ tests/test_merger.py::test_zoom
+ tests/test_merger.py::test_zoom_xyz_no_left
+ tests/test_page.py::test_empyt_password_1088
+ tests/test_page.py::test_extract_text_operator_t_star
+ tests/test_page.py::test_extract_text_page_pdf
+ tests/test_page.py::test_extract_text_page_pdf_impossible_decode_xform
+ tests/test_page.py::test_extract_text_single_quote_op
+ 'tests/test_page.py::test_page_operations[https://arxiv.org/pdf/2201.00029.pdf-None]'
+ tests/test_reader.py::test_extract_text_pdf15
+ tests/test_reader.py::test_extract_text_xref_issue_2
+ tests/test_reader.py::test_extract_text_xref_issue_3
+ tests/test_reader.py::test_extract_text_xref_table_21_bytes_clrf
+ tests/test_reader.py::test_get_fields
+ tests/test_reader.py::test_get_fields_read_else_block
+ tests/test_reader.py::test_get_fields_read_else_block2
+ tests/test_reader.py::test_get_fields_read_else_block3
+ tests/test_reader.py::test_get_fields_read_write_report
+ tests/test_reader.py::test_iss925
+ tests/test_reader.py::test_metadata_is_none
+ tests/test_reader.py::test_outline_color
+ tests/test_reader.py::test_outline_font_format
+ tests/test_reader.py::test_outline_with_empty_action
+ tests/test_reader.py::test_outline_with_missing_named_destination
+ tests/test_reader.py::test_read_form_416
+ tests/test_reader.py::test_unexpected_destination
+ tests/test_reader.py::test_unexpected_destination
+ tests/test_reader.py::test_xfa_non_empty
+ tests/test_reader.py::test_PdfReaderMultipleDefinitions
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_compress
+ tests/test_workflows.py::test_extract_text
+ tests/test_workflows.py::test_extract_textbench
+ tests/test_workflows.py::test_get_fields
+ tests/test_workflows.py::test_get_fonts
+ tests/test_workflows.py::test_get_metadata
+ tests/test_workflows.py::test_get_outline
+ tests/test_workflows.py::test_image_extraction
+ tests/test_workflows.py::test_merge
+ tests/test_workflows.py::test_merge_with_warning
+ tests/test_workflows.py::test_overlay
+ tests/test_workflows.py::test_scale_rectangle_indirect_object
+ tests/test_workflows.py::test_get_xfa
+ tests/test_writer.py::test_sweep_indirect_references_nullobject_exception
+ tests/test_writer.py::test_write_bookmark_on_page_fitv
+ tests/test_xmp.py::test_custom_properties
+ tests/test_xmp.py::test_dc_creator
+ tests/test_xmp.py::test_dc_description
+ tests/test_xmp.py::test_dc_subject
+ tests/test_xmp.py::test_issue585
+ tests/test_xmp.py::test_xmpmm
+ tests/test_merger.py::test_outline_item
+ tests/test_page.py::test_iss_1142
+ tests/test_page.py::test_read_link_annotation
+ tests/test_reader.py::test_named_destination
+ tests/test_writer.py::test_write_outline_item_on_page_fitv
+
+ # TODO
+ tests/test_workflows.py::test_orientations
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${P}"/sample-files/ || die
+ fi
+}