summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-04-30 22:45:12 +1000
committerMichael Palimaka <kensington@gentoo.org>2019-04-30 22:46:28 +1000
commit3a6cf0fad8a57e0ddf138a70d17998722924d511 (patch)
treebc0eacd70a46046ebd83eab86d8a6b3be6385814 /dev-python/PyQt5
parentdev-python/PyQt5: remove 5.9.2 (diff)
downloadgentoo-3a6cf0fad8a57e0ddf138a70d17998722924d511.tar.gz
gentoo-3a6cf0fad8a57e0ddf138a70d17998722924d511.tar.bz2
gentoo-3a6cf0fad8a57e0ddf138a70d17998722924d511.zip
dev-python/PyQt5: fix build with USE="gles2"
Bug: https://bugs.gentoo.org/635502 Thanks-to: Quentin Minster <quentin@minster.io> Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-python/PyQt5')
-rw-r--r--dev-python/PyQt5/PyQt5-5.12.1.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.12.1.ebuild b/dev-python/PyQt5/PyQt5-5.12.1.ebuild
index 37381dcdb825..909fa142cd2c 100644
--- a/dev-python/PyQt5/PyQt5-5.12.1.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.12.1.ebuild
@@ -128,6 +128,7 @@ src_configure() {
$(usex declarative '' --no-qml-plugin)
$(pyqt_use_enable designer)
$(usex designer '' --no-designer-plugin)
+ $(usex gles2 '--disable-feature PyQt_Desktop_OpenGL')
$(pyqt_use_enable gui)
$(pyqt_use_enable gui $(use gles2 && echo _QOpenGLFunctions_ES2 || echo _QOpenGLFunctions_{2_0,2_1,4_1_Core}))
$(pyqt_use_enable help)