summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-17 00:24:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-17 00:48:21 -0400
commit259d30f953e2b11e5c5804080cc86d155dce71f4 (patch)
tree49f6d21a6e134c156a6bd85c001a68924ed7156a /dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
parentdev-python/PyQt6: remove gcc dependency, update hack (diff)
downloadgentoo-259d30f953e2b11e5c5804080cc86d155dce71f4.tar.gz
gentoo-259d30f953e2b11e5c5804080cc86d155dce71f4.tar.bz2
gentoo-259d30f953e2b11e5c5804080cc86d155dce71f4.zip
dev-python/PyQt6-WebEngine: remove gcc dependency, update hack
Turns out that this *can* use clang++ but only if qtbase was built with clang++ as well, otherwise it still uses g++ even with CXX=clang++ But given the former, there is little reason to enforce the dependency. Ideally would use CXX but that would require more elaborate testing to know what it is and what qtbase was built with (perhaps if ever add the hack to qmake-utils.eclass). No revbump given PyQt* bindings are a slowish build and depcleaning gcc is a bit niche, the few interested can handle this manually until next bump. Closes: https://github.com/gentoo/gentoo/pull/31493 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild')
-rw-r--r--dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
index c14617c05118..9e4ab2b11079 100644
--- a/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
+++ b/dev-python/PyQt6-WebEngine/PyQt6-WebEngine-6.5.0.ebuild
@@ -30,16 +30,18 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="
>=dev-python/PyQt-builder-1.15[${PYTHON_USEDEP}]
- >=dev-qt/qtbase-${QT_PV}
- sys-devel/gcc"
+ >=dev-qt/qtbase-${QT_PV}"
src_prepare() {
default
- # hack: qmake queries g++ directly for info (not building) and that doesn't
- # work with clang, this is to make it at least respect CHOST (bug #726112)
+ # hack: qmake queries g++ or clang++ for info depending on which qtbase was
+ # built with, but ignores CHOST failing with -native-symlinks (bug #726112)
+ # and potentially using wrong information when cross-compiling
mkdir "${T}"/cxx || die
- ln -s "$(type -P ${CHOST}-g++ || type -P g++ || die)" "${T}"/cxx/g++ || die
+ local cxx
+ ! cxx=$(type -P "${CHOST}"-g++) || ln -s -- "${cxx}" "${T}"/cxx/g++ || die
+ ! cxx=$(type -P "${CHOST}"-clang++) || ln -s -- "${cxx}" "${T}"/cxx/clang++ || die
PATH=${T}/cxx:${PATH}
}