summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Pritchard <chris@christopherpritchard.co.uk>2021-08-15 09:35:32 +0200
committerDavide Pesavento <pesa@gentoo.org>2021-08-15 09:46:23 +0200
commit3505313b1bc80620f331af7d76f8c23eb76a32a3 (patch)
treee4546f54c9727a0d082e4a6174b7d091ae9322f6 /dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5_pre2108100905.ebuild
parentdev-python/jedi: Skip test_speed in 0.17.2-r1 as well (diff)
downloadgentoo-3505313b1bc80620f331af7d76f8c23eb76a32a3.tar.gz
gentoo-3505313b1bc80620f331af7d76f8c23eb76a32a3.tar.bz2
gentoo-3505313b1bc80620f331af7d76f8c23eb76a32a3.zip
dev-python/PyQtWebEngine: add 5.15.5_pre2108100905, EAPI 8
Switch build system to sip-build Bug: https://bugs.gentoo.org/805965 Closes: https://github.com/gentoo/gentoo/pull/21854 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Chris Pritchard <chris@christopherpritchard.co.uk> Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5_pre2108100905.ebuild')
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5_pre2108100905.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5_pre2108100905.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5_pre2108100905.ebuild
new file mode 100644
index 000000000000..ab5763665826
--- /dev/null
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.5_pre2108100905.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QtWebEngine"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/ https://pypi.org/project/PyQtWebEngine/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.15.5_pre2107091435[gui,network,printsupport,webchannel,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwebengine:5[widgets]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-sip-12.9:=[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/PyQt-builder-1.10[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.2.0_pre2106291255[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+"
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ sip-build
+ --verbose
+ --build-dir="${BUILD_DIR}"
+ --scripts-dir="$(python_get_scriptdir)"
+ --qmake="$(qt5_get_bindir)"/qmake
+ --no-make
+ $(usev debug '--debug --qml-debug --tracing')
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain and build flags
+ run_in_build_dir eqmake5 -recursive ${PN}.pro
+ }
+ python_foreach_impl configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+}