summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-17 13:04:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-17 16:29:06 +0100
commit9cbdae3f9409ccd416cd7b17aa1911bc7397890c (patch)
tree852549b5dd04c19214b20c11223cc48e6d6fb108 /dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild
parentdev-python/PyQt5: Use pypi.eclass (diff)
downloadgentoo-9cbdae3f9409ccd416cd7b17aa1911bc7397890c.tar.gz
gentoo-9cbdae3f9409ccd416cd7b17aa1911bc7397890c.tar.bz2
gentoo-9cbdae3f9409ccd416cd7b17aa1911bc7397890c.zip
dev-python/PyQtWebEngine: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild')
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild
index 8ac077883076..58a9589c5a9a 100644
--- a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.6.ebuild
@@ -3,19 +3,18 @@
EAPI=8
+PYPI_NO_NORMALIZE=1
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-r1 qmake-utils
+inherit pypi python-r1 qmake-utils
DESCRIPTION="Python bindings for QtWebEngine"
HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/ https://pypi.org/project/PyQtWebEngine/"
-MY_P=${PN}-${PV/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
+ MY_P=${PN}-${PV/_pre/.dev}
SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+ S=${WORKDIR}/${MY_P}
fi
-S=${WORKDIR}/${MY_P}
LICENSE="GPL-3"
SLOT="0"