summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 10:22:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:42:33 +0200
commit8b9f4b0a720ab731ff802e826c84fe5729ab756b (patch)
tree927ca6254a6f0b8a80db59d7d330c55f402faad7 /dev-python/PySocks
parentdev-python/platformdirs: Keyword 2.5.2 for ~m68k (diff)
downloadgentoo-8b9f4b0a720ab731ff802e826c84fe5729ab756b.tar.gz
gentoo-8b9f4b0a720ab731ff802e826c84fe5729ab756b.tar.bz2
gentoo-8b9f4b0a720ab731ff802e826c84fe5729ab756b.zip
dev-python/PySocks: Remove obsolete test code
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/PySocks')
-rw-r--r--dev-python/PySocks/PySocks-1.7.1-r1.ebuild34
-rw-r--r--dev-python/PySocks/files/PySocks-1.7.1-test_server.patch33
2 files changed, 2 insertions, 65 deletions
diff --git a/dev-python/PySocks/PySocks-1.7.1-r1.ebuild b/dev-python/PySocks/PySocks-1.7.1-r1.ebuild
index b00817eb5729..5c7528eeac5a 100644
--- a/dev-python/PySocks/PySocks-1.7.1-r1.ebuild
+++ b/dev-python/PySocks/PySocks-1.7.1-r1.ebuild
@@ -4,7 +4,7 @@
# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
@@ -16,35 +16,5 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-#BDEPEND="
-# test? (
-# net-proxy/3proxy
-# $(python_gen_cond_dep 'dev-python/test_server[${PYTHON_USEDEP}]' -3)
-# )"
-
-#distutils_enable_tests pytest
-
-# tests fail semi-randomly; probably starting proxy server doesn't work
-# as expected
+# tests are broken beyond repair and the package is no longer maintained
RESTRICT="test"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/PySocks-1.7.1-test_server.patch
- )
-
- rm test/bin/3proxy || die
-# if use test; then
-# ln -s "${BROOT}/usr/bin/3proxy" test/bin/3proxy || die
-# fi
-
- # requires Internet
- sed -i -e 's:test_socks5_proxy_connect_timeout:_&:' \
- test/test_pysocks.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch b/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch
deleted file mode 100644
index 20d208549720..000000000000
--- a/dev-python/PySocks/files/PySocks-1.7.1-test_server.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 983f0451ed25c755da670a682703ae8f7795782b Mon Sep 17 00:00:00 2001
-From: John Vandenberg <jayvdb@gmail.com>
-Date: Wed, 4 Dec 2019 10:44:14 +0700
-Subject: [PATCH] Update tests for test-server 0.0.31
-
-Closes https://github.com/Anorov/PySocks/issues/117
----
- requirements_dev.txt | 2 +-
- test/test_pysocks.py | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/test/test_pysocks.py b/test/test_pysocks.py
-index 49893b2..03d2649 100644
---- a/test/test_pysocks.py
-+++ b/test/test_pysocks.py
-@@ -79,8 +79,7 @@ def setUpClass(cls):
- from test_server import TestServer
-
- cls.test_server = TestServer(address=TEST_SERVER_HOST,
-- port=TEST_SERVER_PORT,
-- engine='subprocess')
-+ port=TEST_SERVER_PORT)
- cls.test_server.start()
-
- @classmethod
-@@ -112,6 +111,7 @@ def assert_proxy_response(self, resp_data, content, address,
- self.test_server.request['headers']['user-agent'])
- self.assertEqual('%s:%d' % address,
- self.test_server.request['headers']['host'])
-+ content = b'3\r\n' + content + b'\r\n0'
- self.assertEqual(content, resp_body)
- self.assertEqual(client_ip or PROXY_HOST_IP,
- self.test_server.request['client_ip'])