summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-14 08:46:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-14 10:59:08 +0200
commit00ed98181bfae543b471c4a41b89acc1d4ee8b69 (patch)
treef1640872ddcb63014e753389b4b91a695d9cc9ab /dev-python/Pyro4
parentdev-python/Pyro4: slotmove 4 → 0 (diff)
downloadgentoo-00ed98181bfae543b471c4a41b89acc1d4ee8b69.tar.gz
gentoo-00ed98181bfae543b471c4a41b89acc1d4ee8b69.tar.bz2
gentoo-00ed98181bfae543b471c4a41b89acc1d4ee8b69.zip
dev-python/Pyro4: Bump to 4.81
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Pyro4')
-rw-r--r--dev-python/Pyro4/Manifest1
-rw-r--r--dev-python/Pyro4/Pyro4-4.81.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/Pyro4/Manifest b/dev-python/Pyro4/Manifest
index 190cd946887e..2f224e53fb6f 100644
--- a/dev-python/Pyro4/Manifest
+++ b/dev-python/Pyro4/Manifest
@@ -1 +1,2 @@
DIST Pyro4-4.80.tar.gz 515103 BLAKE2B 5d2b69ba020117947a36c9c75f884434a3452167fa2e586e3a5b0e6deb1d0c8c54dd06a20b9568b53a0a6c42a847d880636e3abe37090246d5f34ca84e915b36 SHA512 8e41285674edbe5c8d5ac63e33406c5ff7b6366d5dd251a1755eff81611193278a473ed8b15f995bc0ba2775dc5d316eb6a3cafd63626b95820591ea3a0a92e3
+DIST Pyro4-4.81.tar.gz 514678 BLAKE2B ffe9edcb947203b37cf1b13b2380f2b7d76357a5bca36e454fe67f6bd0d34574f5df429dd784ba2c2bc69c0188edd14e4572f12f5c137d87d2898f01ea3e855c SHA512 3848d473acd624ae1356ad3470c669eb0bc30287691ff8b9fc27fb0591ba305812c6be1946d6a2a91377e222a9e114f05ed18170d1b035dec24e436ab8dadc59
diff --git a/dev-python/Pyro4/Pyro4-4.81.ebuild b/dev-python/Pyro4/Pyro4-4.81.ebuild
new file mode 100644
index 000000000000..8027e01d7312
--- /dev/null
+++ b/dev-python/Pyro4/Pyro4-4.81.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="https://pypi.org/project/Pyro4/
+ https://github.com/irmen/Pyro4"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
+ dev-python/dill[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.6[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable tests requiring network connection.
+ rm tests/PyroTests/test_naming.py || die
+ sed \
+ -e "s/testStartNSfunc/_&/" \
+ -i tests/PyroTests/test_naming2.py || die
+
+ sed \
+ -e "s/testBroadcast/_&/" \
+ -e "s/testGetIP/_&/" \
+ -i tests/PyroTests/test_socket.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}