summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 23:32:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 23:58:43 +0200
commit2f670f844c7f93d1004cc3513ac2ecf8819053f1 (patch)
tree13163de7e337350eaf5f3af7a729eff3f424e932 /dev-python/Rx/Rx-3.2.0.ebuild
parentdev-python/aiorpcX: Bump to 0.22.0 (diff)
downloadgentoo-2f670f844c7f93d1004cc3513ac2ecf8819053f1.tar.gz
gentoo-2f670f844c7f93d1004cc3513ac2ecf8819053f1.tar.bz2
gentoo-2f670f844c7f93d1004cc3513ac2ecf8819053f1.zip
dev-python/Rx: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Rx/Rx-3.2.0.ebuild')
-rw-r--r--dev-python/Rx/Rx-3.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/Rx/Rx-3.2.0.ebuild b/dev-python/Rx/Rx-3.2.0.ebuild
new file mode 100644
index 000000000000..d7dc1233b7a3
--- /dev/null
+++ b/dev-python/Rx/Rx-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY-${PV}"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="
+ https://github.com/ReactiveX/RxPY/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}