summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-08-16 07:20:12 +0200
committerSlawomir Lis <slis@gentoo.org>2019-08-16 07:21:37 +0200
commitef87f734ad1a9d4d572f7cc5b86b0a60917e040c (patch)
tree26cc5b05bb81ca0914ff3eda591ba65b1dd9d7d8 /dev-python/URLObject/URLObject-2.4.3.ebuild
parentqmail.eclass: do not install man templates to section 8 (diff)
downloadgentoo-ef87f734ad1a9d4d572f7cc5b86b0a60917e040c.tar.gz
gentoo-ef87f734ad1a9d4d572f7cc5b86b0a60917e040c.tar.bz2
gentoo-ef87f734ad1a9d4d572f7cc5b86b0a60917e040c.zip
dev-python/URLObject: version bump to 2.4.3
Package-Manager: Portage-2.3.71, Repoman-2.3.16 Signed-off-by: Slawek Lis <slis@gentoo.org>
Diffstat (limited to 'dev-python/URLObject/URLObject-2.4.3.ebuild')
-rw-r--r--dev-python/URLObject/URLObject-2.4.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/URLObject/URLObject-2.4.3.ebuild b/dev-python/URLObject/URLObject-2.4.3.ebuild
new file mode 100644
index 000000000000..b628b00bb781
--- /dev/null
+++ b/dev-python/URLObject/URLObject-2.4.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+
+inherit distutils-r1
+
+GITHUB_P=${P,,}
+DESCRIPTION="A utility class for manipulating URLs"
+HOMEPAGE="https://pypi.org/project/URLObject/"
+# note: pypi tarball lacks tests
+# https://github.com/zacharyvoase/urlobject/issues/39
+SRC_URI="https://github.com/zacharyvoase/urlobject/archive/v${PV}.tar.gz -> ${GITHUB_P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+S=${WORKDIR}/${GITHUB_P}
+
+python_test() {
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}