summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 15:42:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:42:19 +0200
commit40deaf8385d15f9c681bb4da06219785488d49e0 (patch)
tree1efb7f715bd27dbeb84e2f9334d06e7c4edf1eb3 /dev-python/aiodns/aiodns-1.2.0.ebuild
parentdev-python/pycares: Restore RESTRICT=test (diff)
downloadgentoo-40deaf8385d15f9c681bb4da06219785488d49e0.tar.gz
gentoo-40deaf8385d15f9c681bb4da06219785488d49e0.tar.bz2
gentoo-40deaf8385d15f9c681bb4da06219785488d49e0.zip
dev-python/aiodns: Bump to 1.2.0, py3.7, EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiodns/aiodns-1.2.0.ebuild')
-rw-r--r--dev-python/aiodns/aiodns-1.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/aiodns/aiodns-1.2.0.ebuild b/dev-python/aiodns/aiodns-1.2.0.ebuild
new file mode 100644
index 000000000000..3f3766200b23
--- /dev/null
+++ b/dev-python/aiodns/aiodns-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+$(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' -2)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}