summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 15:55:06 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:55:06 +0200
commite63650d8eeaf35cf693b08835bb75557d378e0f1 (patch)
tree0fb6617acdb9f02e8ab7ad729a30e8eb932aea52 /dev-python/aiodns
parentdev-python/aiodns: Bump to 1.2.0, py3.7, EAPI 7 (diff)
downloadgentoo-e63650d8eeaf35cf693b08835bb75557d378e0f1.tar.gz
gentoo-e63650d8eeaf35cf693b08835bb75557d378e0f1.tar.bz2
gentoo-e63650d8eeaf35cf693b08835bb75557d378e0f1.zip
dev-python/aiodns: Bump to 2.0.0 (without py2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest1
-rw-r--r--dev-python/aiodns/aiodns-2.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index 300d641b6e0e..186058660e6c 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1,2 +1,3 @@
DIST aiodns-1.1.1.tar.gz 6084 BLAKE2B 8e58cedcf288f87ca9cc8d5f067bdf182f220979aba3d2aa53eb998ae877dcaa7c2a7419a50719ba150fdf17271d025668b28a3212fc5a819bf13129b4fb25a2 SHA512 4bd8b80a10f84b82b13ba4ff6abbb1afd13ba6cfececc4db7c4bd303569473316f1c0e083f1017a450875fc8994a70c30c9a1b3fb2278fee5e27158973bc3810
DIST aiodns-1.2.0.tar.gz 6457 BLAKE2B c1035e5a31b179665be1c7c75e3e8f6665e04c43d5f2bada7e0d7ef76f17d99d2d86c2bd5063fbda2d2947c7a4aa1e21e66cef070019da6bf56e94d716edc0ea SHA512 2e80c275d98f54378b121cafe4680221f29eb57346976b3c476c7110fcb215892744982de25736193663ab4ac3f3cf516fa38b664e3303e6c67180ed6c31e21b
+DIST aiodns-2.0.0.tar.gz 5948 BLAKE2B 70944ffbfa3fa1c591c5aab6ce2c4c59564a7665fd2eda1b544616a4481e58464f918081dfb21f74db08ebe4c7e43eebd17e0dc314cf79423835a182a257cd11 SHA512 d80b8f7641234c4d367e4554b10c5a66265e75ee82c58adf2a36f9e369bb1dbf4341dd6459f10540b771de3f102454511ca81eddf3082733e88c09bbdf125fe0
diff --git a/dev-python/aiodns/aiodns-2.0.0.ebuild b/dev-python/aiodns/aiodns-2.0.0.ebuild
new file mode 100644
index 000000000000..7763f5b57eb9
--- /dev/null
+++ b/dev-python/aiodns/aiodns-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}