summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-09-18 16:35:52 -0700
committerZac Medico <zmedico@gentoo.org>2016-09-18 16:38:14 -0700
commitecba64766321bfe2309a363021336adfb72157c2 (patch)
treec32f2df55cd754088872e4c2e76aea85c9a3e9bf /dev-python/aiodns
parentprofiles: remove stale chromium masks (diff)
downloadgentoo-ecba64766321bfe2309a363021336adfb72157c2.tar.gz
gentoo-ecba64766321bfe2309a363021336adfb72157c2.tar.bz2
gentoo-ecba64766321bfe2309a363021336adfb72157c2.zip
dev-python/aiodns: add package (bug 533584)
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest1
-rw-r--r--dev-python/aiodns/aiodns-1.1.1.ebuild30
-rw-r--r--dev-python/aiodns/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
new file mode 100644
index 000000000000..934bdf2a8f08
--- /dev/null
+++ b/dev-python/aiodns/Manifest
@@ -0,0 +1 @@
+DIST aiodns-1.1.1.tar.gz 6084 SHA256 d8677adc679ce8d0ef706c14d9c3d2f27a0e0cc11d59730cdbaf218ad52dd9ea SHA512 4bd8b80a10f84b82b13ba4ff6abbb1afd13ba6cfececc4db7c4bd303569473316f1c0e083f1017a450875fc8994a70c30c9a1b3fb2278fee5e27158973bc3810 WHIRLPOOL e4e45bc4b9ad7ce290e1c9039bfdf8858f1fc3e6e33e5e8b35a373c1193f4f70c9de44afe4d99ad8bcef85673e4bcd075b7896e62cba49f52c6e7a15a3f0696f
diff --git a/dev-python/aiodns/aiodns-1.1.1.ebuild b/dev-python/aiodns/aiodns-1.1.1.ebuild
new file mode 100644
index 000000000000..9cfa55ca4a6b
--- /dev/null
+++ b/dev-python/aiodns/aiodns-1.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+ python_targets_python2_7? (
+ dev-python/trollius[python_targets_python2_7]
+ )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON:-python}" tests.py || die
+}
diff --git a/dev-python/aiodns/metadata.xml b/dev-python/aiodns/metadata.xml
new file mode 100644
index 000000000000..8d8dfc10de75
--- /dev/null
+++ b/dev-python/aiodns/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">aiodns</remote-id>
+ <remote-id type="github">saghul/aiodns</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>