summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-05 08:59:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-05 09:17:57 +0200
commit11bf3450cc4d457da056bb25c3e6f57317189fa7 (patch)
tree0fd5209bc6ec6e39004f038d43b71854d79e043f /dev-python/aiofiles
parentdev-python/fritzconnection: Bump to 1.10.2 (diff)
downloadgentoo-11bf3450cc4d457da056bb25c3e6f57317189fa7.tar.gz
gentoo-11bf3450cc4d457da056bb25c3e6f57317189fa7.tar.bz2
gentoo-11bf3450cc4d457da056bb25c3e6f57317189fa7.zip
dev-python/aiofiles: Bump to 22.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiofiles')
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-22.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index e977198d0f0d..3fe27aed75e1 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1 +1,2 @@
DIST aiofiles-0.8.0.tar.gz 24139 BLAKE2B 0f113b75832219e63c0894e70ec613138db7e243ad032bc6d7bf715aab505b5246ab7a0add64b46a9b981801cf05885f7affa965cb625941dc57b805280f0ff1 SHA512 4f590baa0369d465a6139c0d4f50beeec60f8f213b607e0e41598f45f507a12edc67b29c77718b03eee7532f10ead8599f55aac3fcb78d0429435c25a58f6d2e
+DIST aiofiles-22.1.0.gh.tar.gz 21630 BLAKE2B 8f068046fc143388debc93b657f8b4715cd48eac7e7b8a031ccdc6d2f5764ddcafb2ad1fab713ca55366cad951b570e1c2a120932bf5545482e1a3f086a76bf9 SHA512 6706fb7b6fd32df415ece64f35b8ccc2f263301c43292612b2b6173fb66c77bc88fd08ed0b0bb30fa3dd49571be8fc733a3d4f3611228fdbb368743588336357
diff --git a/dev-python/aiofiles/aiofiles-22.1.0.ebuild b/dev-python/aiofiles/aiofiles-22.1.0.ebuild
new file mode 100644
index 000000000000..6b02b37e3b7e
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-22.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+SRC_URI="
+ https://github.com/Tinche/aiofiles/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest