summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-01-29 20:06:59 +0900
committerAaron Bauman <bman@gentoo.org>2017-01-29 20:16:38 +0900
commitf85cda0c70fd51660ca8d8fc165fe358de27472c (patch)
tree350a1d686e64544cf7480bdbc2a2321af2b24d23 /dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
parentx11-misc/parcellite: Version bump (bug 607550, thanks Arnaud Vallette d'Osia). (diff)
downloadgentoo-f85cda0c70fd51660ca8d8fc165fe358de27472c.tar.gz
gentoo-f85cda0c70fd51660ca8d8fc165fe358de27472c.tar.bz2
gentoo-f85cda0c70fd51660ca8d8fc165fe358de27472c.zip
dev-python/aiohttp-cors: new package needed by net-misc/gns3-server
Diffstat (limited to 'dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild')
-rw-r--r--dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild b/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
new file mode 100644
index 000000000000..ce58bea79fdf
--- /dev/null
+++ b/dev-python/aiohttp-cors/aiohttp-cors-0.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements CORS support for aiohttp asyncio-powered asynchronous HTTP server"
+HOMEPAGE="https://github.com/aio-libs/aiohttp-cors"
+SRC_URI="https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp-cors"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND=">=dev-python/aiohttp-1.1.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"