summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-01 22:46:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-01 22:53:31 +0100
commit30e4d3541794b14fe305200c1dade21ef364a384 (patch)
treef14b12545bd5b759de1c045718682b8c5f475651 /dev-python/aiohttp-socks
parentdev-python/python-socks: Bump to 1.2.2 (diff)
downloadgentoo-30e4d3541794b14fe305200c1dade21ef364a384.tar.gz
gentoo-30e4d3541794b14fe305200c1dade21ef364a384.tar.bz2
gentoo-30e4d3541794b14fe305200c1dade21ef364a384.zip
dev-python/aiohttp-socks: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp-socks')
-rw-r--r--dev-python/aiohttp-socks/Manifest1
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.6.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index 3d6454f443ff..74c690f96caa 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1 +1,2 @@
DIST aiohttp-socks-0.5.5.tar.gz 1349283 BLAKE2B 85cd19fdc8c549a1c8ed66a71a9ccb61093fa6febfc2b2e93e26e47be9fc4d319f0ceecc0d6f70739e861fe5f7cd8c78615dfe67ed0669049d38da1f89da33f2 SHA512 94b9d5fc5a5eb04ce16302ca4a1abdaf8ec2b31811a6156aa3667aeb5bd284fc1757a65dc8dc7b77450017a04aa315a908a52a4d38b0657c41bcd64b9b1605b9
+DIST aiohttp-socks-0.6.0.tar.gz 19789 BLAKE2B 56a9279f78e2a7a391183e6b68f9b33d878dc9b328d3096ca649b136e321ed372a9f9e8f7a02282c32568ac458639bd76b341f87722eeac46741d68064cc035b SHA512 15a5869d24955cba9548d8bd7cf1ec29b27a024603ca1b1d4abf8f93c70702434542c66ced1d8b28ae851034dad1ae8e2eaa4ed9a3729be35ec1e3c853237811
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.6.0.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.6.0.ebuild
new file mode 100644
index 000000000000..e47d2dc6625e
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="https://pypi.org/project/aiohttp-socks/"
+SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest