summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-07 15:29:34 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-07 15:29:56 -0500
commitcd21a9376d38b324a0254d91f8aa9d6b5178695a (patch)
tree1ebb0ceec93355b5cc3ba09281ca5c4eb7fd43d6 /dev-python/aiohttp/aiohttp-0.17.4.ebuild
parentwww-client/chromium: dev channel bump (47.0.2526.6); add system-ffmpeg USE flag (diff)
downloadgentoo-cd21a9376d38b324a0254d91f8aa9d6b5178695a.tar.gz
gentoo-cd21a9376d38b324a0254d91f8aa9d6b5178695a.tar.bz2
gentoo-cd21a9376d38b324a0254d91f8aa9d6b5178695a.zip
dev-python/aiohttp: add version 0.17.4
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-python/aiohttp/aiohttp-0.17.4.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-0.17.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/aiohttp/aiohttp-0.17.4.ebuild b/dev-python/aiohttp/aiohttp-0.17.4.ebuild
new file mode 100644
index 000000000000..5efb49618e0d
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-0.17.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/aiohttp/aiohttp-0.14.4-r1.ebuild,v 1.1 2015/03/16 11:08:45 bman Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://github.com/KeepSafe/aiohttp https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+CDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/asyncio[${PYTHON_USEDEP}]' 'python3_3')
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python3_3')
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="$(PWD):${PYTHONPATH}" nosetests tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}