summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-16 10:15:35 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-16 10:16:22 -0600
commit64d95172eba2d9a5561fe438073e4aea543bc7ca (patch)
treec8efd0c3aea58e69aaf2ba2de35e525a799a2f30 /dev-python/aiohttp/aiohttp-0.18.4.ebuild
parentvirtual/python-dnspython: amd64 stable wrt bug #565742 (diff)
downloadgentoo-64d95172eba2d9a5561fe438073e4aea543bc7ca.tar.gz
gentoo-64d95172eba2d9a5561fe438073e4aea543bc7ca.tar.bz2
gentoo-64d95172eba2d9a5561fe438073e4aea543bc7ca.zip
dev-python/aiohttp: add version 0.18.4
x86 was dropped due to dev-python/pytest-raisesregexp. Bug #565956 has been filed to remedy this. Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/aiohttp/aiohttp-0.18.4.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-0.18.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/aiohttp/aiohttp-0.18.4.ebuild b/dev-python/aiohttp/aiohttp-0.18.4.ebuild
new file mode 100644
index 000000000000..1f7cb32c1e3a
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-0.18.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://github.com/KeepSafe/aiohttp https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples test"
+
+CDEPEND=" dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-raisesregexp[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="$(PWD):${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}