summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-01-09 15:20:48 -0600
committerAlex Brandt <alunduil@gentoo.org>2016-01-09 17:16:41 -0600
commit507321c95d9ab8a918fe24deb1e5f931c40b822b (patch)
treecd3c3f5c40b17ee3716f5c6e7337116c4433eefe /dev-python/aiohttp/aiohttp-0.20.2.ebuild
parentnet-misc/dhcpcd: remove old unstable versions (diff)
downloadgentoo-507321c95d9ab8a918fe24deb1e5f931c40b822b.tar.gz
gentoo-507321c95d9ab8a918fe24deb1e5f931c40b822b.tar.bz2
gentoo-507321c95d9ab8a918fe24deb1e5f931c40b822b.zip
dev-python/aiohttp: add version 0.20.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/aiohttp/aiohttp-0.20.2.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-0.20.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/aiohttp/aiohttp-0.20.2.ebuild b/dev-python/aiohttp/aiohttp-0.20.2.ebuild
new file mode 100644
index 000000000000..ab8be7d6cd66
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-0.20.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://github.com/KeepSafe/aiohttp https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+CDEPEND="dev-python/chardet[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-raisesregexp[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="$(PWD):${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}