summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-07-30 12:10:55 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-02 10:40:54 +0200
commita9d6c55003cc899cb9dfc77846233b6aa6b2fb9e (patch)
treefd24f47f739e7f2aa32af504f0e2a83a9cbac8cd /dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
parentdev-python/pytest-aiohttp: enable pypy3 (diff)
downloadgentoo-a9d6c55003cc899cb9dfc77846233b6aa6b2fb9e.tar.gz
gentoo-a9d6c55003cc899cb9dfc77846233b6aa6b2fb9e.tar.bz2
gentoo-a9d6c55003cc899cb9dfc77846233b6aa6b2fb9e.zip
dev-python/aiohttp: enable pypy3
Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild')
-rw-r--r--dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild b/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
index 4c0cea0a0d1e..1010ecc1021f 100644
--- a/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
+++ b/dev-python/aiohttp/aiohttp-3.7.4-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1 multiprocessing
@@ -91,6 +91,11 @@ python_test() {
'tests/test_streams.py::TestDataQueue::test_exception_waiter[pyloop]'
)
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ # fails with a 'runtime warning'
+ tests/test_multipart.py::TestPartReader::test_read_boundary_with_incomplete_chunk
+ )
+
pushd "${BUILD_DIR}/lib" >/dev/null || die
ln -snf "${S}"/{LICENSE.txt,tests} . || die
epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" --forked \