summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-28 09:22:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-28 10:03:38 +0100
commit834ce22cd77d3ee068dd73b494e3e5bc0dd25f6a (patch)
treed54ef91aae111de03754593437efc4559871da2a /dev-python/aioredis
parentdev-python/pytest-httpx: Bump to 0.17.3 (diff)
downloadgentoo-834ce22cd77d3ee068dd73b494e3e5bc0dd25f6a.tar.gz
gentoo-834ce22cd77d3ee068dd73b494e3e5bc0dd25f6a.tar.bz2
gentoo-834ce22cd77d3ee068dd73b494e3e5bc0dd25f6a.zip
dev-python/aioredis: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aioredis')
-rw-r--r--dev-python/aioredis/Manifest1
-rw-r--r--dev-python/aioredis/aioredis-2.0.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/aioredis/Manifest b/dev-python/aioredis/Manifest
index 3464ef7fb086..4c3b3911a2f2 100644
--- a/dev-python/aioredis/Manifest
+++ b/dev-python/aioredis/Manifest
@@ -1 +1,2 @@
DIST aioredis-2.0.0.tar.gz 110808 BLAKE2B c10b7d9ba9a6878d3a28f9cada836acbceb7d62525cfc65a52fc3a15edebf5b736ad81f249477e30d1f920473067f27048530f7fd4d0a45cb5391976eb6e4c3e SHA512 edc738215bdb1459af8657f06b8194cdfbb6814f4d40b723e11a1fdec5607b73033eca0bffac758afa2cca9532de910a508c9fb27c5885952426266a14c21eee
+DIST aioredis-2.0.1.tar.gz 111047 BLAKE2B 56f520110bee1a5ef2c19171b6c4c5d6cd4ac440892d36edc4ebf274e7b4ac184fd9e090ad79922f609de4b1dc403a1caa38b271cb1f938357ab9f01ea3f8bfc SHA512 9c2c3fe3e4e4a91e9ca727f8ad78c7c4e6ce1109e4a3043d9ddb929606b6879b1522f3845a3b18d8586ed557a4ab0f6288f27f2b6b0e307343e113f9b9b5fd76
diff --git a/dev-python/aioredis/aioredis-2.0.1.ebuild b/dev-python/aioredis/aioredis-2.0.1.ebuild
new file mode 100644
index 000000000000..12e63e82d7d8
--- /dev/null
+++ b/dev-python/aioredis/aioredis-2.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1 optfeature
+
+DESCRIPTION="asyncio Redis client library"
+HOMEPAGE="https://pypi.org/project/aioredis/ https://github.com/aio-libs/aioredis-py"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/hiredis[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ elog "Spawning Redis"
+ elog "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+pkg_postinst() {
+ optfeature "hiredis parser" dev-python/hiredis
+}