summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-25 09:47:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-25 09:55:32 +0200
commitc3768e7a05c42c525d4c6e02c41bd678b4382526 (patch)
treecc207c6b984916061075f57cb56fe859a9f0192f /dev-python/aiostream/aiostream-0.5.2.ebuild
parentdev-python/m2crypto: Enable py3.12 (diff)
downloadgentoo-c3768e7a05c42c525d4c6e02c41bd678b4382526.tar.gz
gentoo-c3768e7a05c42c525d4c6e02c41bd678b4382526.tar.bz2
gentoo-c3768e7a05c42c525d4c6e02c41bd678b4382526.zip
dev-python/aiostream: Bump to 0.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiostream/aiostream-0.5.2.ebuild')
-rw-r--r--dev-python/aiostream/aiostream-0.5.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/aiostream/aiostream-0.5.2.ebuild b/dev-python/aiostream/aiostream-0.5.2.ebuild
new file mode 100644
index 000000000000..d07884312d93
--- /dev/null
+++ b/dev-python/aiostream/aiostream-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generator-based operators for asynchronous iteration"
+HOMEPAGE="
+ https://pypi.org/project/aiostream/
+ https://github.com/vxgmichel/aiostream/
+"
+SRC_URI="
+ https://github.com/vxgmichel/aiostream/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov aiostream --cov-report html --cov-report term::' \
+ setup.cfg || die
+ distutils-r1_src_prepare
+}