summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 14:21:52 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 15:11:19 +0200
commit61f3e526032224494d723103b49637dc95d15d0f (patch)
treec90e5245d27cb27b1b191345501798ac5b9af5b2 /dev-python/alembic/alembic-0.8.2.ebuild
parentdev-python/flask-script: Clean old versions up (diff)
downloadgentoo-61f3e526032224494d723103b49637dc95d15d0f.tar.gz
gentoo-61f3e526032224494d723103b49637dc95d15d0f.tar.bz2
gentoo-61f3e526032224494d723103b49637dc95d15d0f.zip
dev-python/alembic: Clean old versions up
Diffstat (limited to 'dev-python/alembic/alembic-0.8.2.ebuild')
-rw-r--r--dev-python/alembic/alembic-0.8.2.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/alembic/alembic-0.8.2.ebuild b/dev-python/alembic/alembic-0.8.2.ebuild
deleted file mode 100644
index fa4a3b450e1c..000000000000
--- a/dev-python/alembic/alembic-0.8.2.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_4 )
-
-inherit distutils-r1
-
-DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
-HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test doc"
-
-# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
-# because it shatters the testsuite. If 'someone' cares to adhere to correct form
-# and edit to -0.7.3, feel free, and then pick up the pieces.
-RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-# For test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # suite passes all if run from source. The residual fail & error are quite erroneous
- rm tests/test_script_consumption.py
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
-
- distutils-r1_python_install_all
-}