summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-21 11:24:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-21 11:24:06 +0100
commit2ddfb1f5c3f6796550951b75069d6e79bcdc0d0e (patch)
tree20a6516a6ef4b53ca8fbda29c00577c729bc39e6 /dev-python/alembic/alembic-1.5.2.ebuild
parentdev-python/bleach: Bump to 3.2.2 (diff)
downloadgentoo-2ddfb1f5c3f6796550951b75069d6e79bcdc0d0e.tar.gz
gentoo-2ddfb1f5c3f6796550951b75069d6e79bcdc0d0e.tar.bz2
gentoo-2ddfb1f5c3f6796550951b75069d6e79bcdc0d0e.zip
dev-python/alembic: Bump to 1.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic/alembic-1.5.2.ebuild')
-rw-r--r--dev-python/alembic/alembic-1.5.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-1.5.2.ebuild b/dev-python/alembic/alembic-1.5.2.ebuild
new file mode 100644
index 000000000000..32d428a7bdf3
--- /dev/null
+++ b/dev-python/alembic/alembic-1.5.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}