summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-24 08:19:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-24 08:41:07 +0100
commit0df03eddf3da922d961369666560a47c7abe7046 (patch)
tree488c0123fce40296f20ea42b184ce2b8ddcaea1c /dev-python/alembic
parentdev-libs/libretls: Bump to 3.7.0 (diff)
downloadgentoo-0df03eddf3da922d961369666560a47c7abe7046.tar.gz
gentoo-0df03eddf3da922d961369666560a47c7abe7046.tar.bz2
gentoo-0df03eddf3da922d961369666560a47c7abe7046.zip
dev-python/alembic: Bump to 1.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.9.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index d5733e4aeeb1..c8be98e3dc00 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,2 +1,3 @@
DIST alembic-1.8.1.tar.gz 1255927 BLAKE2B dbf40f9ca12171d99ad46bec6bf1841799226887a55a815db5c7a69cbcb7d861ede774aa35e1018e1a57bec26a8ddf7ee311e0b4396ebddd5477c67a4ad11876 SHA512 51f210447172d08eb94c41a962ddecc593a665790aa6f5badb771dccc882e0d653dcf153ebb04b9824dabcaeb1ac08e3747c2e3c74d8584a24b35662778de8dd
DIST alembic-1.9.0.tar.gz 1278832 BLAKE2B 59131c5a53d051905c13e466c58ad5c1759e0e0f557bcb78bbe80e2ca8f3f7d791a1d8be017cd9227d6baf8b7416d0c6d89ec9e9e56f7440f6d1455577ed8676 SHA512 3c040ee07ce2f40af28a63f129dee886f7d8458b762a28cf2165ac10dd2f2f732b73da2ae2c9687b66e8872b75d85d95933847eb6a1190ad55e550e6bb120a04
+DIST alembic-1.9.1.tar.gz 1280020 BLAKE2B 2355b265a7cb42091f51e2d291dd2e620134f9f7ef96c101db7161e1a8667b44ddb61b6d01f46a0db4227b44dcc1821c9bd6923f8510c4235e26f3d482e4298a SHA512 143a62bab08c654c5846ff7ba1021dfb96d3a4b0e699d9c4bd692fda250f47b0ee10cb3238b769e8117b09ac495bdd97a6dbd290b29659b5121754be9a161331
diff --git a/dev-python/alembic/alembic-1.9.1.ebuild b/dev-python/alembic/alembic-1.9.1.ebuild
new file mode 100644
index 000000000000..be24ef80d028
--- /dev/null
+++ b/dev-python/alembic/alembic-1.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}