summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 08:47:28 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 09:31:10 +0200
commitb18001e86cac6dc1035ec9311aa9a6b9d6f3a3d1 (patch)
tree53f41d7b1491be38caef4e0f618b902a634ae325 /dev-python/alembic
parentdev-python/python-editor: Use PEP517, EAPI 8, py3.11 (diff)
downloadgentoo-b18001e86cac6dc1035ec9311aa9a6b9d6f3a3d1.tar.gz
gentoo-b18001e86cac6dc1035ec9311aa9a6b9d6f3a3d1.tar.bz2
gentoo-b18001e86cac6dc1035ec9311aa9a6b9d6f3a3d1.zip
dev-python/alembic: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-1.8.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 96dd6cefc897..8a37f7d89600 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1 +1,2 @@
DIST alembic-1.8.0.tar.gz 1252636 BLAKE2B dfe6130a08a8bfcdeb10e02187a9f597bb55de8194c91909ab06d72f5daaaaf4c7154570a141a82be8568195d8f5f76db661f1dd192b92a5991434ade1a389ed SHA512 601366f21bcadaef1a5b7f7d4a1edfd9c146340f8a5d07b41e3b381e1e00866e79520d8393330e4a80369664b36b549c9d5ab3ea13ad7aa8010b165e73038bcd
+DIST alembic-1.8.1.tar.gz 1255927 BLAKE2B dbf40f9ca12171d99ad46bec6bf1841799226887a55a815db5c7a69cbcb7d861ede774aa35e1018e1a57bec26a8ddf7ee311e0b4396ebddd5477c67a4ad11876 SHA512 51f210447172d08eb94c41a962ddecc593a665790aa6f5badb771dccc882e0d653dcf153ebb04b9824dabcaeb1ac08e3747c2e3c74d8584a24b35662778de8dd
diff --git a/dev-python/alembic/alembic-1.8.1.ebuild b/dev-python/alembic/alembic-1.8.1.ebuild
new file mode 100644
index 000000000000..be24ef80d028
--- /dev/null
+++ b/dev-python/alembic/alembic-1.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="
+ https://github.com/sqlalchemy/alembic/
+ https://pypi.org/project/alembic/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}