summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-31 20:28:03 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-31 21:20:22 +0300
commit4c3bb19506ded8d18b5945417c8ad948bcb663ee (patch)
tree3c9941b62b838376e995637cc6a11893acd0e0b2 /dev-python/allpairspy
parentdev-python/botocore: add 1.27.42 (diff)
downloadgentoo-4c3bb19506ded8d18b5945417c8ad948bcb663ee.tar.gz
gentoo-4c3bb19506ded8d18b5945417c8ad948bcb663ee.tar.bz2
gentoo-4c3bb19506ded8d18b5945417c8ad948bcb663ee.zip
dev-python/allpairspy: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/allpairspy')
-rw-r--r--dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild b/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..c28ca8f108ca
--- /dev/null
+++ b/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pairwise test combinations generator"
+HOMEPAGE="https://github.com/thombashi/allpairspy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest