summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-03-19 02:07:38 -0400
committerTim Harder <radhermit@gentoo.org>2018-03-19 02:07:38 -0400
commit3f26f40359b64ee905230944912f46285add8558 (patch)
tree5b1192ec11a16d0c0a46a3883592ad4355982107 /dev-python/aniso8601
parentdev-python/bleach: version bump to 2.1.3 (diff)
downloadgentoo-3f26f40359b64ee905230944912f46285add8558.tar.gz
gentoo-3f26f40359b64ee905230944912f46285add8558.tar.bz2
gentoo-3f26f40359b64ee905230944912f46285add8558.zip
dev-python/aniso8601: version bump to 3.0.0
Diffstat (limited to 'dev-python/aniso8601')
-rw-r--r--dev-python/aniso8601/Manifest1
-rw-r--r--dev-python/aniso8601/aniso8601-3.0.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/aniso8601/Manifest b/dev-python/aniso8601/Manifest
index 0c56d0af4fa0..3d6eea75808c 100644
--- a/dev-python/aniso8601/Manifest
+++ b/dev-python/aniso8601/Manifest
@@ -1,3 +1,4 @@
DIST aniso8601-1.2.0.tar.gz 59998 BLAKE2B b580255a074580ecda15fb042ce0f7388d2419fda8b1507b77eab4d0004c74fa033d87c76e71af4429953a27a4ef5f43f8d0b4ca0a82a4cc68f19a47e3073347 SHA512 1918ee5a22c0ca3fd7cf331ca4f06dff93b73cc7865276e0e276b70e7ade7db0cbc10020619be23d73d646dc15764cb597084e0b5d632c1ee5dd21d29fb33311
DIST aniso8601-1.2.1.tar.gz 62369 BLAKE2B aa4d02327aefa5315b9116e1f3b2fa77762c309b6d9a4f4aee6d05e6c187e0642046f8f691bf9b97d341470d30052101f512d9fd1e5473e0f475b735ce279881 SHA512 92a323ee4d275437a02936c396da483dd064e0756fc38f869f5e3fa3b1dde59bd1b285f5602efb4ea7c6ced1a633008898c832d6fcd3b9d7f996dbaf25e061e7
DIST aniso8601-1.3.0.tar.gz 57730 BLAKE2B 7844add7f785371f69a8a473c0706edb76f994fccc99ae2cce3b56cd3a55041364bd08848acbd606453f4b8bfa3a80d063fc86ed49155817dc9fb8b7024c8e73 SHA512 33054b3bb07c26fda4af09c606dfa90be1fdebaa49efa8f508df72d339eb8f8b525ac2bad5d410098bbf1c88483823ad663649cf32f2806a9ee6e9ad46d53e8f
+DIST aniso8601-3.0.0.tar.gz 69371 BLAKE2B 7dabeb013df414db6ade982595cb95514eb408855641ac2a6552f4ab1e646d478c2435a2b1537149fcbcffa076a913b45b644163585377cf98036d898ed1154c SHA512 bea2b9dad8f8ac2c5314570ce49846ef0cdf6459019065b5529966fbaf20a79d76b7af5a93f5bb8e1d811d3355a217877ae90d295529f3e9a7b2b20e6465b1c7
diff --git a/dev-python/aniso8601/aniso8601-3.0.0.ebuild b/dev-python/aniso8601/aniso8601-3.0.0.ebuild
new file mode 100644
index 000000000000..eed3a54c73ea
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-3.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.python.org/pypi/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${PYTHON}" -m unittest discover ${PN}/tests || die "Tests fail with ${EPYTHON}"
+}