summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2018-08-01 15:59:44 +0300
committerSergey Popov <pinkbyte@gentoo.org>2018-08-01 15:59:44 +0300
commit5e677253c3a88520c768a78c9be6d88c3b0659c4 (patch)
tree2a1a38df127b9a56d68a27bbd2d11dff48e0657d /dev-python/ansi/ansi-0.1.3.ebuild
parentdev-python/daemonize: new package (diff)
downloadgentoo-5e677253c3a88520c768a78c9be6d88c3b0659c4.tar.gz
gentoo-5e677253c3a88520c768a78c9be6d88c3b0659c4.tar.bz2
gentoo-5e677253c3a88520c768a78c9be6d88c3b0659c4.zip
dev-python/ansi: new package
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/ansi/ansi-0.1.3.ebuild')
-rw-r--r--dev-python/ansi/ansi-0.1.3.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/ansi/ansi-0.1.3.ebuild b/dev-python/ansi/ansi-0.1.3.ebuild
new file mode 100644
index 000000000000..e1e76f207625
--- /dev/null
+++ b/dev-python/ansi/ansi-0.1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI cursor movement and graphics in Python"
+HOMEPAGE="https://github.com/tehmaze/ansi"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${P}"