summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-01-15 00:40:28 +0100
committerSebastian Pipping <sping@gentoo.org>2018-01-15 00:58:10 +0100
commit2afd3441b99e18681bfeda82185e6abfe59182aa (patch)
treea4a14c9186c174eb738224aae764a0c9805b6586 /dev-python/ansi2html/ansi2html-1.3.0.ebuild
parentx11-misc/zim: 0.68_rc1 (diff)
downloadgentoo-2afd3441b99e18681bfeda82185e6abfe59182aa.tar.gz
gentoo-2afd3441b99e18681bfeda82185e6abfe59182aa.tar.bz2
gentoo-2afd3441b99e18681bfeda82185e6abfe59182aa.zip
dev-python/ansi2html: 1.3.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/ansi2html/ansi2html-1.3.0.ebuild')
-rw-r--r--dev-python/ansi2html/ansi2html-1.3.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.3.0.ebuild b/dev-python/ansi2html/ansi2html-1.3.0.ebuild
new file mode 100644
index 000000000000..e8c9113901fd
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.python.org/pypi/ansi2html https://github.com/ralphbean/ansi2html"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc test"
+
+# They miserably fail.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( app-text/asciidoc )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ )
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+
+src_compile() {
+ use doc && emake man/${PN}.1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ chmod -x "${S}"/tests/* || die
+ esetup.py check
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && doman man/${PN}.1
+ DOCS=( README.rst man/${PN}.1.txt )
+ distutils-r1_python_install_all
+}