summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-11-05 15:45:01 +0100
committerSebastian Pipping <sping@gentoo.org>2023-11-05 15:45:23 +0100
commit6e1871645858ce48c5cb4d26a74b4b1682b877ec (patch)
tree638e7fcd42fea93a01a79fabbc49eabbe9878f9b /dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild
parentwww-apps/nikola: Add missing revbump (diff)
downloadgentoo-6e1871645858ce48c5cb4d26a74b4b1682b877ec.tar.gz
gentoo-6e1871645858ce48c5cb4d26a74b4b1682b877ec.tar.bz2
gentoo-6e1871645858ce48c5cb4d26a74b4b1682b877ec.zip
dev-python/ansi2html: Drop dev-python/setuptools_scm_git_archive dependency
Closes: https://bugs.gentoo.org/916891 Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild')
-rw-r--r--dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild b/dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild
new file mode 100644
index 000000000000..6cddd195fb25
--- /dev/null
+++ b/dev-python/ansi2html/ansi2html-1.8.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert text with ANSI color codes to HTML"
+HOMEPAGE="https://pypi.org/project/ansi2html/
+ https://github.com/pycontribs/ansi2html"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+
+RDEPEND=">=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ doman man/${PN}.1
+ distutils-r1_python_install_all
+}