summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-11 18:37:57 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-11 18:38:20 +0000
commitf99978d822bd5f39598909e79458f55e71c77bca (patch)
tree3f98e773b2a5bfb94483dd81952e89b7d4546736 /dev-python/ansible-compat
parentdev-python/pytest-testinfra: enable py3.10 (diff)
downloadgentoo-f99978d822bd5f39598909e79458f55e71c77bca.tar.gz
gentoo-f99978d822bd5f39598909e79458f55e71c77bca.tar.bz2
gentoo-f99978d822bd5f39598909e79458f55e71c77bca.zip
dev-python/ansible-compat: add 1.0.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/ansible-compat')
-rw-r--r--dev-python/ansible-compat/Manifest1
-rw-r--r--dev-python/ansible-compat/ansible-compat-1.0.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/ansible-compat/Manifest b/dev-python/ansible-compat/Manifest
index 942408e367d8..5471b0454288 100644
--- a/dev-python/ansible-compat/Manifest
+++ b/dev-python/ansible-compat/Manifest
@@ -1 +1,2 @@
DIST ansible-compat-0.5.0.tar.gz 32913 BLAKE2B 468dbcf20865225c76896dd8aad6f4b9a749b7a45d661484f89e2eaab4416b29f2e0ea0477b86ea52193165cd23180a79ebd5adac571e0b7d659096e84c27bcb SHA512 3ea219ceda313daf923d11ff45c31a760ddbae7ac782b1f89316eb29960a8028fab4e7e242fa0247c6ef5824d71ff9f22ae8956af73dda261a69713110e3db8e
+DIST ansible-compat-1.0.0.tar.gz 34729 BLAKE2B 56eb32314e310777e454a5f5e020cc4dfc485e6d5720d45e99734ce8cf238377f1ff443f9f78f5b9de947944564a7001294907c0e186fe94cd4561d4d348723e SHA512 dd02b47acf38b378016acbe6f2e6494df1cbf68d88a0cb685a5f594ee24b23af1c4d14878090ba7ea69f76185afb57eeb546cc40a6038171eebc991401c6e241
diff --git a/dev-python/ansible-compat/ansible-compat-1.0.0.ebuild b/dev-python/ansible-compat/ansible-compat-1.0.0.ebuild
new file mode 100644
index 000000000000..e963e3ab20d9
--- /dev/null
+++ b/dev-python/ansible-compat/ansible-compat-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Contains functions that facilitate working with various versions of Ansible"
+HOMEPAGE="https://pypi.org/project/ansible-compat/ https://github.com/ansible-community/ansible-compat/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-admin/ansible-base-2.9.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/subprocess-tee-0.3.5[${PYTHON_USEDEP}]
+"
+BDEPEND="$(python_gen_cond_dep '
+ >=dev-python/setuptools_scm-6.3.1[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-markdown[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-plus[${PYTHON_USEDEP}]
+ )
+')"
+
+# All these tests attempt to connect to galaxy.ansible.com
+EPYTEST_DESELECT=(
+ test/test_runtime.py::test_install_collection
+ test/test_runtime.py::test_install_collection_dest
+ test/test_runtime.py::test_prepare_environment_with_collections
+ test/test_runtime.py::test_prerun_reqs_v1
+ test/test_runtime.py::test_prerun_reqs_v2
+ test/test_runtime.py::test_require_collection_no_cache_dir
+ test/test_runtime.py::test_require_collection_wrong_version
+ test/test_runtime.py::test_require_collection
+ test/test_runtime.py::test_upgrade_collection
+ test/test_runtime_example.py::test_runtime
+)
+
+# Requires currently unpackaged Sphinx extension myst_parser
+#distutils_enable_sphinx docs 'dev-python/sphinx_ansible_theme'
+
+distutils_enable_tests pytest