summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucian Poston <lucianposton@pm.me>2020-02-25 15:11:01 -0600
committerJoonas Niilola <juippis@gentoo.org>2020-02-27 15:54:42 +0200
commit0975ddab3af4e2a65e7dbb9262a64e752fcd271b (patch)
tree4080f9ca09bd3b1c7a7129b0840c4b5b2acd944b /dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
parentdev-python/ansicolor: Add maintainer (diff)
downloadgentoo-0975ddab3af4e2a65e7dbb9262a64e752fcd271b.tar.gz
gentoo-0975ddab3af4e2a65e7dbb9262a64e752fcd271b.tar.bz2
gentoo-0975ddab3af4e2a65e7dbb9262a64e752fcd271b.zip
dev-python/ansicolor: Add python3_{7,8}
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Lucian Poston <lucianposton@pm.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild')
-rw-r--r--dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild b/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
new file mode 100644
index 000000000000..25c10321fe62
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-0.2.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/numerodix/ansicolor.git"
+ # pypi tars don't include tests and github repo is missing release tags,
+ # so only enabling tests for 9999 at this time
+ distutils_enable_tests pytest
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+
+LICENSE="Apache-2.0"
+SLOT="0"