summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-05-05 11:24:41 -0400
committerSam James <sam@gentoo.org>2024-05-05 20:48:42 +0100
commit13420a564969779e3148bb504b970dd56d5a2112 (patch)
treefb6728f7673f9b6b6cc12f142f161ed25c8bcd8f /dev-python/anyio/anyio-4.3.0-r1.ebuild
parentapp-misc/lcd4linux: Fix implicit declaration of function open (diff)
downloadgentoo-13420a564969779e3148bb504b970dd56d5a2112.tar.gz
gentoo-13420a564969779e3148bb504b970dd56d5a2112.tar.bz2
gentoo-13420a564969779e3148bb504b970dd56d5a2112.zip
dev-python/anyio: drop exceptiongroup stdlib backport to test dep
It was historically needed for python 3.10 support, as a backport. In anyio 4.1.0, it was also unconditionally used in the testsuite. Instead of copying the dep over to the test? USE, the ebuild added it at runtime... Fixes: b87901374f7596e6ec81a4bb228b5a1dd831c41e Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/anyio/anyio-4.3.0-r1.ebuild')
-rw-r--r--dev-python/anyio/anyio-4.3.0-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/anyio/anyio-4.3.0-r1.ebuild b/dev-python/anyio/anyio-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..5636aa635281
--- /dev/null
+++ b/dev-python/anyio/anyio-4.3.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.23[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..12})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}