summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-13 10:22:42 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-13 11:02:58 +0200
commitc4a92df7b473c523351a9dd5ba769b464b77d6a1 (patch)
treee9657f9e01494298010a1b74ba7213bd1b2d7e6a /dev-python/appdirs/appdirs-1.4.4.ebuild
parentsci-libs/fftw: Workaround missing -mavx2 with avx2 flag (diff)
downloadgentoo-c4a92df7b473c523351a9dd5ba769b464b77d6a1.tar.gz
gentoo-c4a92df7b473c523351a9dd5ba769b464b77d6a1.tar.bz2
gentoo-c4a92df7b473c523351a9dd5ba769b464b77d6a1.zip
dev-python/appdirs: Add missing ebuild for 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/appdirs/appdirs-1.4.4.ebuild')
-rw-r--r--dev-python/appdirs/appdirs-1.4.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/appdirs/appdirs-1.4.4.ebuild b/dev-python/appdirs/appdirs-1.4.4.ebuild
new file mode 100644
index 000000000000..fcb6e362e930
--- /dev/null
+++ b/dev-python/appdirs/appdirs-1.4.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# note the patch below
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for determining appropriate platform-specific dirs"
+HOMEPAGE="https://github.com/ActiveState/appdirs"
+SRC_URI="https://github.com/ActiveState/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.4.4-distutils.patch )
+
+python_test() {
+ "${PYTHON}" test/test_api.py -v || die "Tests fail with ${EPYTHON}"
+}