summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/apse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/apse')
-rw-r--r--dev-python/apse/Manifest1
-rw-r--r--dev-python/apse/apse-0.2-r3.ebuild41
-rw-r--r--dev-python/apse/metadata.xml16
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/apse/Manifest b/dev-python/apse/Manifest
new file mode 100644
index 000000000000..559c1f926a28
--- /dev/null
+++ b/dev-python/apse/Manifest
@@ -0,0 +1 @@
+DIST Apse-0.2.tar.gz 18005 SHA256 cacdb5fa76bc63998bae65c858797423d8b5c047290a762ab9e299097faa983f SHA512 accad6d4fa4056e5dd0ac1036b47b6e258ceea9b458ca91065b0a8411d5e3a3461cd8e87bebbf884982d02bc0f6cc996a3df800fe74a0567a336ee79e05a9837 WHIRLPOOL 912327a3d5ca2f8a20c41604a67323f7c97c71aa1a4120498420bb335eb081e33c39b5bab1de80d0a693b54cefbd91eeefca644fba100182d45e27454bd70b8e
diff --git a/dev-python/apse/apse-0.2-r3.ebuild b/dev-python/apse/apse-0.2-r3.ebuild
new file mode 100644
index 000000000000..c332281524af
--- /dev/null
+++ b/dev-python/apse/apse-0.2-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P="Apse-${PV}"
+
+DESCRIPTION="Approximate String Matching in Python"
+HOMEPAGE="http://www.personal.psu.edu/staff/i/u/iua1/python/apse/"
+SRC_URI="http://www.personal.psu.edu/staff/i/u/iua1/python/${PN}/dist/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ppc64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-lang/swig:1"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Prevent the build system from calling swig over and over again.
+ sed -i -e 's:Apse.i:Apse_wrap.c:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ set -- swig1.3 -python -o Apse_wrap.c Apse.i
+ echo "${@}" >&2
+ "${@}" || die
+}
+
+python_test() {
+ "${PYTHON}" test/test_Apse.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/apse/metadata.xml b/dev-python/apse/metadata.xml
new file mode 100644
index 000000000000..104473b5e099
--- /dev/null
+++ b/dev-python/apse/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Approximate String Matching in Python: identifies typing and spelling
+ errors, closely related vocabularies, genetic mutations (GAG ACT),
+ abbreviations. While it implements the same algorithm as the agrep
+ program, Apse lets the user choose how many edits (substitutions,
+ deletions, additions) will be acceptable as 'match'.
+ </longdescription>
+ <longdescription lang="ja">
+ Python言語に近似した文字列の一致を判断させます。タイピング・エラー、スペリング・
+ エラー、ボキャブラリ的に近い単語、一般的な同意語(GAG ACT)、略語を同一視できます>。agrepプログラムと同一のアルゴリズムを用いて、Apseはユーザーに"一致する"と判断>した場合の処理(置換、削除、追加)を何回行うかを選ばせます。
+ </longdescription>
+</pkgmetadata>