summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-03 08:25:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-03 08:26:51 +0200
commitd4e559f168c9399ed0876f052e7c6c820b70ca92 (patch)
tree631ecba5bd298d7e977ba624994907499c448605 /dev-python/apsw/apsw-3.32.2_p1.ebuild
parentdev-python/aiorpcX: Remove old (diff)
downloadgentoo-d4e559f168c9399ed0876f052e7c6c820b70ca92.tar.gz
gentoo-d4e559f168c9399ed0876f052e7c6c820b70ca92.tar.bz2
gentoo-d4e559f168c9399ed0876f052e7c6c820b70ca92.zip
dev-python/apsw: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw/apsw-3.32.2_p1.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.32.2_p1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/apsw/apsw-3.32.2_p1.ebuild b/dev-python/apsw/apsw-3.32.2_p1.ebuild
deleted file mode 100644
index 2dcb9f8967c8..000000000000
--- a/dev-python/apsw/apsw-3.32.2_p1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=${PV/_p/-r}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="https://github.com/rogerbinns/apsw/"
-SRC_URI="https://github.com/rogerbinns/apsw/releases/download/${MY_PV}/${MY_P}.zip -> ${P}.zip"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc64 x86"
-IUSE="doc"
-
-RDEPEND=">=dev-db/sqlite-${PV%_p*}"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}/${MY_P}
-
-PATCHES=( "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch" )
-
-python_compile() {
- distutils-r1_python_compile --enable=load_extension
-}
-
-python_test() {
- "${PYTHON}" setup.py build_test_extension || die "Building of test loadable extension failed"
- "${PYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/. )
- distutils-r1_python_install_all
-}