summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-27 10:12:03 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-27 17:06:16 +0100
commit6e473e12cec57e6961d6baedfe82bad42180feef (patch)
tree58eab3fd18cb671d004297f824261ded7a3a1676 /dev-python/argcomplete/argcomplete-1.10.3.ebuild
parentsys-fs/lvm2: Revbump to fix unsupported udev option (diff)
downloadgentoo-6e473e12cec57e6961d6baedfe82bad42180feef.tar.gz
gentoo-6e473e12cec57e6961d6baedfe82bad42180feef.tar.bz2
gentoo-6e473e12cec57e6961d6baedfe82bad42180feef.zip
dev-python/argcomplete: Bump to 1.10.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/argcomplete/argcomplete-1.10.3.ebuild')
-rw-r--r--dev-python/argcomplete/argcomplete-1.10.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.10.3.ebuild b/dev-python/argcomplete/argcomplete-1.10.3.ebuild
new file mode 100644
index 000000000000..d5066a924d7a
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-1.10.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7,3_8} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.org/project/argcomplete/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pip
+ )"
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}