summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@chromium.org>2018-03-28 22:40:58 -0400
committerMike Frysinger <vapier@gentoo.org>2018-03-28 22:41:05 -0400
commitc7e3cca930e8e1acdac7b3d1cbbc23b6ab129eae (patch)
treed615f04c4fc027df77054673ffa639f8b32174d7 /dev-python/argcomplete/argcomplete-1.9.4.ebuild
parenteclass: misc spelling fixes (diff)
downloadgentoo-c7e3cca930e8e1acdac7b3d1cbbc23b6ab129eae.tar.gz
gentoo-c7e3cca930e8e1acdac7b3d1cbbc23b6ab129eae.tar.bz2
gentoo-c7e3cca930e8e1acdac7b3d1cbbc23b6ab129eae.zip
dev-python/argcomplete: version bump to 1.9.4
Diffstat (limited to 'dev-python/argcomplete/argcomplete-1.9.4.ebuild')
-rw-r--r--dev-python/argcomplete/argcomplete-1.9.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/argcomplete/argcomplete-1.9.4.ebuild b/dev-python/argcomplete/argcomplete-1.9.4.ebuild
new file mode 100644
index 000000000000..a696b02ca808
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-1.9.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="https://pypi.python.org/pypi/argcomplete"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~arm ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ app-shells/tcsh
+ )"
+
+python_test() {
+ "${EPYTHON}" test/test.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newbashcomp "${S}"/${PN}/bash_completion.d/python-argcomplete.sh python-${PN}
+}