summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-08-23 12:52:03 -0700
committerZac Medico <zmedico@gentoo.org>2016-08-23 13:14:17 -0700
commita5d69286542b10be4e725b84e526278abf5a12e2 (patch)
tree71ec5d50b58032da0c5530af1237f8252ec33762 /dev-python/arpeggio/arpeggio-1.5.ebuild
parentmedia-gfx/dpic: Remove name node. (diff)
downloadgentoo-a5d69286542b10be4e725b84e526278abf5a12e2.tar.gz
gentoo-a5d69286542b10be4e725b84e526278abf5a12e2.tar.bz2
gentoo-a5d69286542b10be4e725b84e526278abf5a12e2.zip
dev-python/arpeggio: add package
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/arpeggio/arpeggio-1.5.ebuild')
-rw-r--r--dev-python/arpeggio/arpeggio-1.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/arpeggio/arpeggio-1.5.ebuild b/dev-python/arpeggio/arpeggio-1.5.ebuild
new file mode 100644
index 000000000000..1557bc4efdcb
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-1.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN=Arpeggio
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.python.org/pypi/${MY_PN} https://github.com/igordejanovic/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+# pypi tarball omits tests
+RESTRICT="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ py.test -v tests || die "tests failed"
+}