summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-04-26 18:37:22 -0700
committerZac Medico <zmedico@gentoo.org>2020-04-26 18:40:05 -0700
commit72cf78766ca89a0dc71b7401dcdd7c62097743c8 (patch)
treea6f1c655ed67188f5b1bc0a75f57f7bb842d0d39 /dev-python/arpeggio/arpeggio-1.9.2.ebuild
parentnet-libs/libtorrent-rasterbar: add back py3.6 support (diff)
downloadgentoo-72cf78766ca89a0dc71b7401dcdd7c62097743c8.tar.gz
gentoo-72cf78766ca89a0dc71b7401dcdd7c62097743c8.tar.bz2
gentoo-72cf78766ca89a0dc71b7401dcdd7c62097743c8.zip
dev-python/arpeggio: Bump to version 1.9.2
Reported-by: Alex Barker <alex@1stleg.com> Closes: https://bugs.gentoo.org/719478 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/arpeggio/arpeggio-1.9.2.ebuild')
-rw-r--r--dev-python/arpeggio/arpeggio-1.9.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/arpeggio/arpeggio-1.9.2.ebuild b/dev-python/arpeggio/arpeggio-1.9.2.ebuild
new file mode 100644
index 000000000000..5623c7389bdf
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-1.9.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+MY_PN=Arpeggio
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/igordejanovic/Arpeggio"
+SRC_URI="https://github.com/igordejanovic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e 's:packages=find_packages(:\0exclude=["examples", "examples.*"]:' -i setup.py || die
+}
+
+python_test() {
+ pytest -vv || die "Testing failed"
+}