summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-26 00:48:12 +0100
committerSam James <sam@gentoo.org>2021-09-26 04:40:35 +0100
commit3155ed2b1a255baeaa11255934ce0c959b3dcef5 (patch)
treede17a67f3d9d61d152566b6b88ea73176b83535c /dev-python/astroid/astroid-2.6.6.ebuild
parentdev-python/pylint: drop 2.9.6 (diff)
downloadgentoo-3155ed2b1a255baeaa11255934ce0c959b3dcef5.tar.gz
gentoo-3155ed2b1a255baeaa11255934ce0c959b3dcef5.tar.bz2
gentoo-3155ed2b1a255baeaa11255934ce0c959b3dcef5.zip
dev-python/astroid: drop 2.6.6
Bug: https://bugs.gentoo.org/814854 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/astroid/astroid-2.6.6.ebuild')
-rw-r--r--dev-python/astroid/astroid-2.6.6.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/astroid/astroid-2.6.6.ebuild b/dev-python/astroid/astroid-2.6.6.ebuild
deleted file mode 100644
index 5cf0a2860c2e..000000000000
--- a/dev-python/astroid/astroid-2.6.6.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="
- https://github.com/PyCQA/astroid/
- https://pypi.org/project/astroid/"
-SRC_URI="
- https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86"
-
-# Version specified in __pkginfo__.py.
-RDEPEND="
- >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local deselect=(
- # no clue why it's broken
- tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
- )
-
- # Faker causes sys.path_importer_cache keys to be overwritten
- # with PosixPaths
- epytest -p no:faker ${deselect[@]/#/--deselect }
-}