summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-14 22:06:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-14 23:35:23 +0200
commit885ea8711b245660054e2fbd6c31ef035b300c88 (patch)
tree94002d038f3001d0dc7d8a06aa8b7f3751353fb1 /dev-python/astroid/astroid-2.8.0.ebuild
parentdev-python/google-api-python-client: Bump to 2.21.0 (diff)
downloadgentoo-885ea8711b245660054e2fbd6c31ef035b300c88.tar.gz
gentoo-885ea8711b245660054e2fbd6c31ef035b300c88.tar.bz2
gentoo-885ea8711b245660054e2fbd6c31ef035b300c88.zip
dev-python/astroid: Bump to 2.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/astroid/astroid-2.8.0.ebuild')
-rw-r--r--dev-python/astroid/astroid-2.8.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/astroid/astroid-2.8.0.ebuild b/dev-python/astroid/astroid-2.8.0.ebuild
new file mode 100644
index 000000000000..cda705df7b1d
--- /dev/null
+++ b/dev-python/astroid/astroid-2.8.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="
+ https://github.com/PyCQA/astroid/
+ https://pypi.org/project/astroid/"
+SRC_URI="
+ https://github.com/PyCQA/astroid/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+ >=dev-python/lazy-object-proxy-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local deselect=(
+ # no clue why it's broken
+ tests/unittest_modutils.py::GetModulePartTest::test_known_values_get_builtin_module_part
+ )
+
+ # Faker causes sys.path_importer_cache keys to be overwritten
+ # with PosixPaths
+ epytest -p no:faker ${deselect[@]/#/--deselect }
+}