summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-21 16:09:48 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 16:09:48 +0200
commitf62fa7fd2f8adfd105f48b0a6b2af679461357f3 (patch)
treebf0c9e1c3435ca57df2513c7524c0fd10ac1bffa /dev-python/astropy
parentmedia-fonts/source-pro: remove self as maintainer (diff)
downloadgentoo-f62fa7fd2f8adfd105f48b0a6b2af679461357f3.tar.gz
gentoo-f62fa7fd2f8adfd105f48b0a6b2af679461357f3.tar.bz2
gentoo-f62fa7fd2f8adfd105f48b0a6b2af679461357f3.zip
dev-python/astropy: Drop live ebuild
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/astropy-9999.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/dev-python/astropy/astropy-9999.ebuild b/dev-python/astropy/astropy-9999.ebuild
deleted file mode 100644
index 634d5beb5eb7..000000000000
--- a/dev-python/astropy/astropy-9999.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1 git-r3
-
-DESCRIPTION="Core functionality for performing astrophysics with Python"
-HOMEPAGE="http://astropy.org/"
-EGIT_REPO_URI="https://github.com/astropy/astropy.git"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc test"
-
-RDEPEND="
- >=dev-libs/expat-2.1.0:0=
- dev-python/configobj[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-astronomy/erfa-1.2:0=
- >=sci-astronomy/wcslib-4.25:0=
- >=sci-libs/cfitsio-3.350:0=
- sys-libs/zlib:0="
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- media-gfx/graphviz
- )
- test? (
- dev-libs/libxml2[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.4-disable_helper.patch"
- "${FILESDIR}/${PN}-1.0.4-system-six.patch"
- "${FILESDIR}/${P}-system-pytest.patch"
- "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
- )
-
-python_prepare_all() {
- export mydistutilsargs="--offline"
- rm -r ${PN}_helpers || die
- cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
- rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
- #rm -rvf ${PN}/extern/* || die
- #{configobj,{six,pytest,configobj}.py} || die
-
- cat >> setup.cfg <<-EOF
-
- [build]
- use_system_libraries=1
- EOF
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- python_export_best
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- py.test -vv -k "not test_web_profile" astropy || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}