summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 10:10:34 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:05 +0200
commit6dba53f88da5c805648ec353b8c4294e2fd50ab3 (patch)
tree419ea7c484afde723278fd5165701271273b8d4b /dev-python/async_generator
parentdev-python/sphinx-aiohttp-theme: Bump to 0.1.5, EAPI=7, Py3.7 (diff)
downloadgentoo-6dba53f88da5c805648ec353b8c4294e2fd50ab3.tar.gz
gentoo-6dba53f88da5c805648ec353b8c4294e2fd50ab3.tar.bz2
gentoo-6dba53f88da5c805648ec353b8c4294e2fd50ab3.zip
dev-python/async_generator: Enable Python 3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async_generator')
-rw-r--r--dev-python/async_generator/async_generator-1.10.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/async_generator/async_generator-1.10.ebuild b/dev-python/async_generator/async_generator-1.10.ebuild
index 7e17bf06efda..c21b9a6072b9 100644
--- a/dev-python/async_generator/async_generator-1.10.ebuild
+++ b/dev-python/async_generator/async_generator-1.10.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit distutils-r1
DESCRIPTION="Making it easy to write async iterators in Python 3.5"
HOMEPAGE="https://github.com/python-trio/async_generator https://pypi.org/project/async_generator/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
LICENSE="|| ( MIT Apache-2.0 )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
+
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
DOCS=( README.rst )
python_test() {
- py.test -v || die "tests failed under ${EPYTHON}"
+ pytest -vv || die "tests failed under ${EPYTHON}"
}