summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-03 06:50:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-03 07:37:39 +0200
commit091c535991790debb0923d76939c555de875613a (patch)
treebce4608957d7d485b59751e9a26f003f076c34d9 /dev-python/asyncstdlib
parentdev-python/coverage: Bump to 6.4.1 (diff)
downloadgentoo-091c535991790debb0923d76939c555de875613a.tar.gz
gentoo-091c535991790debb0923d76939c555de875613a.tar.bz2
gentoo-091c535991790debb0923d76939c555de875613a.zip
dev-python/asyncstdlib: Bump to 3.10.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asyncstdlib')
-rw-r--r--dev-python/asyncstdlib/Manifest1
-rw-r--r--dev-python/asyncstdlib/asyncstdlib-3.10.5.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/asyncstdlib/Manifest b/dev-python/asyncstdlib/Manifest
index e2bc46e22f06..c126eec5dbbb 100644
--- a/dev-python/asyncstdlib/Manifest
+++ b/dev-python/asyncstdlib/Manifest
@@ -1 +1,2 @@
DIST asyncstdlib-3.10.4.gh.tar.gz 52905 BLAKE2B 7b71e816395ab9e33ad4bd3d78d62e8260b78d736ba8b70bb6c47d9d4bbcc431f4a54b8c604e4b520df11a5317a7ab1a70d765e40089b323f985217a943eb96b SHA512 ced64809f1a8d1f60ed045bef69ff6cef84fbcf1b4587c70421112cdc65d6344bb1fceeb55e64e17237a00672bbfff19d4627371b45e1e7659e405d506abf216
+DIST asyncstdlib-3.10.5.gh.tar.gz 54697 BLAKE2B b8a99a83e97084c4e09ddac0402ca23a8d42921b72774c0658aa0b9a1aa0ac1329baae782f105a52a4b6d979d490d97814ea6eac0e7570a7ca27784a27fa5c4d SHA512 3dfa8d1e5e2ef02dbf52fe7094b68496066978cfa9839cad59222ace40e0871369b45d93c1caa87e0f029c328253f6d72d8377625a8ed182498280662fcb7545
diff --git a/dev-python/asyncstdlib/asyncstdlib-3.10.5.ebuild b/dev-python/asyncstdlib/asyncstdlib-3.10.5.ebuild
new file mode 100644
index 000000000000..c1603924e233
--- /dev/null
+++ b/dev-python/asyncstdlib/asyncstdlib-3.10.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="The missing async toolbox"
+HOMEPAGE="
+ https://github.com/maxfischer2781/asyncstdlib/
+ https://pypi.org/project/asyncstdlib/
+"
+SRC_URI="
+ https://github.com/maxfischer2781/asyncstdlib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest