summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-19 10:37:24 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-19 10:45:23 +0100
commit656bc7085cffe90b6244d21f1366248333fcdb75 (patch)
treec3a833233fbb82af8a7e1303dc30674396703f9d /dev-python/attrs/attrs-15.2.0.ebuild
parentnet-news/quiterss: version bump (diff)
downloadgentoo-656bc7085cffe90b6244d21f1366248333fcdb75.tar.gz
gentoo-656bc7085cffe90b6244d21f1366248333fcdb75.tar.bz2
gentoo-656bc7085cffe90b6244d21f1366248333fcdb75.zip
dev-python/attrs: New package, ebuild written by mee
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/attrs/attrs-15.2.0.ebuild')
-rw-r--r--dev-python/attrs/attrs-15.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/attrs/attrs-15.2.0.ebuild b/dev-python/attrs/attrs-15.2.0.ebuild
new file mode 100644
index 000000000000..30d0ade16f42
--- /dev/null
+++ b/dev-python/attrs/attrs-15.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/hynek/attrs
+ https://attrs.readthedocs.org/
+ http://pypi.python.org/pypi/attrs"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v -v || die
+}