summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-15 09:51:07 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-15 09:59:55 +0100
commitacd8acd5b409a505ca13a39169dbce7ad1ae3f80 (patch)
treea8aed811e7e8d95045b4db99b30ebbd0ff7678b4 /dev-python/attrs
parentapp-emacs/sokoban: amd64/x86 stable, (ALLARCHES policy) wrt bug #700074 (diff)
downloadgentoo-acd8acd5b409a505ca13a39169dbce7ad1ae3f80.tar.gz
gentoo-acd8acd5b409a505ca13a39169dbce7ad1ae3f80.tar.bz2
gentoo-acd8acd5b409a505ca13a39169dbce7ad1ae3f80.zip
dev-python/attrs: Bump to 19.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/attrs')
-rw-r--r--dev-python/attrs/Manifest1
-rw-r--r--dev-python/attrs/attrs-19.3.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/attrs/Manifest b/dev-python/attrs/Manifest
index bb3e2b63a196..b81780b1c751 100644
--- a/dev-python/attrs/Manifest
+++ b/dev-python/attrs/Manifest
@@ -1,2 +1,3 @@
DIST attrs-18.2.0.tar.gz 116817 BLAKE2B 79d50c9b49956bbc1e04084eed36a5f65f2dda8e954b23f15650cb881d6f77a8325e042c6d1a77dcad43661d4524a4d253d96bd0053464ef03091779636e6d0b SHA512 58c26579d6dfcacbe9e3f770a125861e0625d435f1293eebe0d62efc9b8aa9572be2b312d73037a647163bffb0a13b240fb157aff7ed35196f637ae945d61d22
DIST attrs-19.1.0.tar.gz 124220 BLAKE2B a7a8321857c2723398db3b7943f221cc141f2d365b84d3f77ccd16c9180fb1d73402c7a1018d70b666bf76b6021bd90df14d792886c1345752b8fc810ac54a35 SHA512 22ee45e8b10a7abe10e720788c5cfab424d0bfe70e595dfb116928b8ebea497a747e8234d96549da00f0967de750fb943db0cd3669354253a27be2ca30fe413a
+DIST attrs-19.3.0.tar.gz 132477 BLAKE2B 6577f39fc15c9e70f0f76ba358099e83c57e226574cb11dbe83747f12e285a284e9d1a218fc1670e0d08be550d42c67cde132604b2cf385d1ee25bda7e57e79a SHA512 b5b641e6732156d1454ed6c49e3a6b29200a8d3f1515fb59aeb85fcb5e9ab6a1d760904de45083cae5250e7bf1a7aa2c1f3ede217240a63f989ae4bb484f2511
diff --git a/dev-python/attrs/attrs-19.3.0.ebuild b/dev-python/attrs/attrs-19.3.0.ebuild
new file mode 100644
index 000000000000..a36ceb872a19
--- /dev/null
+++ b/dev-python/attrs/attrs-19.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Attributes without boilerplate"
+HOMEPAGE="
+ https://github.com/hynek/attrs
+ https://attrs.readthedocs.org/
+ https://pypi.org/project/attrs/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ >=dev-python/hypothesis-3.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.3.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest